查看: 44004|回复: 680

[指标技术] 变色布林带

  [复制链接]

该用户从未签到

28

主题

445

帖子

0

贡献值

功行圆满

Rank: 9Rank: 9Rank: 9

现货币
54 枚
在线时间
2088 小时
发表于 2012-11-6 21:40:47 | 显示全部楼层 |阅读模式
游客,如果您要查看本帖隐藏内容请回复
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复

使用道具 举报

该用户从未签到

0

主题

26

帖子

0

贡献值

初学乍练

Rank: 1

现货币
6 枚
在线时间
1 小时
发表于 2014-1-5 00:03:02 | 显示全部楼层
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR8:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
BB:=EMA((VAR6-VAR8)/(VARB-VAR8)*100,13);
VARC:=EMA(0.667*REF(BB,1)+0.333*BB,2);
波:BB,POINTDOT,COLOR0000A8;
RSV1:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K1:=SMA(RSV1,13,1);
D1:=SMA(K1,13,1);
浪:EMA(D1,3),LINETHICK0,POINTDOT,COLORYELLOW;
天界:90,COLORF00FF0;
中界:50,POINTDOT,COLORWHITE;
地界:10,COLOR00FF00;
VAR1:=(HIGH+LOW+CLOSE)/3;
VAR2:=(VAR1-MA(VAR1,14))/(0.015*AVEDEV(VAR1,14));
VAR28:=IF(DATE<=1120930,1,0);
VAR3:=(VAR1-MA(VAR1,70))/(0.015*AVEDEV(VAR1,70));
VAR4:=IF(VAR2>=150 AND VAR2<200 AND VAR3>=150 AND VAR3<200,10,0);
VAR5:=IF(VAR2<=-150 AND VAR2>-200 AND VAR3<=-150 AND VAR3>-200,-10,VAR4);
VAR16:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR7:=100-ABS(VAR16);
VAR18:=IF(VAR7<90,VAR7,100);
PJX:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
短期强弱:=PJX*VAR28,LINETHICK2,COLORFFFFFF;
VAR1A:=IF(PJX>0,PJX,0);
VAR1B:=IF(VAR3>=200 AND VAR2>=150,15,IF(VAR3<=-200 AND VAR2<=-150,-15,VAR5))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR18<100;
VAR1D:=VAR1A<48 AND VAR1B<60 AND VAR18<100;
DRAWTEXT(VAR1D AND COUNT(VAR1D,30)=1,80,'短线反弹'),COLORFFFFFF;
STICKLINE(VAR1D AND COUNT(VAR1D,30)=1,60,80,5,0),COLORFFFFFF;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,80,'短线高点'),COLORFFCC66;
STICKLINE(VAR1C AND COUNT(VAR1C,30)=1,60,80,5,0),COLORFFCC66;
VAR2C:=IF(VAR3>=200 AND VAR2>=150,15,IF(VAR3<=-200 AND VAR2<=-150,-15,0))+30;
VAR2E:=VAR1A<48 AND VAR2C<30 AND VAR18<100;
VAR2F:=VAR1A<48 AND VAR2C>30 AND VAR18<100;
DRAWTEXT(VAR2E AND COUNT(VAR2E,30)=1,50,'短线反弹2'),COLORFF0000;
STICKLINE(VAR2E AND COUNT(VAR2E,30)=1,30,50,5,0),COLORFF0000;
DRAWTEXT(VAR2F AND COUNT(VAR2F,30)=1,50,'短线高点2'),COLORFFCC66;
STICKLINE(VAR2F AND COUNT(VAR2F,30)=1,30,50,5,0),COLORFFCC66;
VAR3D:=IF(VAR3<=200 AND VAR2<=150,-15,IF(VAR3>=-200 AND VAR2>=-150,15,VAR5));
VAR3E:=VAR3D>0 AND VAR18<100;
VAR3F:=VAR1A<48 AND VAR3D<0 AND VAR18<100;
DRAWTEXT(VAR7<90 AND VAR2+VAR3<=0 AND VAR3F AND COUNT(VAR3F,30)=1,20,'短线反弹3'),COLORFF0000;
STICKLINE(VAR7<90 AND VAR2+VAR3<=0 AND VAR3F AND COUNT(VAR3F,30)=1,20,0,5,0),COLORFF0000;
DRAWTEXT(VAR3E AND COUNT(VAR3E,30)=1,20,'短线高点3'),COLORFFCC66;
STICKLINE(VAR3E AND COUNT(VAR3E,30)=1,20,0,5,0),COLORFFCC66;
VAR9:=IF(VAR7<90,40,30)*VAR28;
STICKLINE(FILTER(VAR1B=45,5),0,5,5,0),COLORFFFFFF;
DRAWTEXT(FILTER(VAR1B=45,10),10,'低吸'),COLORFFFFFF;
STICKLINE(FILTER(VAR1B=75,5),90,80,5,0),COLOR00FFFF;
DRAWTEXT(FILTER(VAR1B=75,5),80,'高抛'),COLOR00FFFF;
STICKLINE(PJX<=-19,0,10,12,0),COLORFF00FF;
STICKLINE(PJX>=70,90,100,12,0),COLOR00FFFF;

STICKLINE((BB-VARC>0),BB,VARC,6,0),COLOR0000A8;
STICKLINE((BB-VARC>0),BB,VARC,5,0),COLOR0000C0;
STICKLINE((BB-VARC>0),BB,VARC,4,0),COLOR0000E0;
STICKLINE((BB-VARC>0),BB,VARC,3,0),COLOR0000F0;
STICKLINE((BB-VARC>0),BB,VARC,2,0),COLOR0000D0;
STICKLINE((BB-VARC>0),BB,VARC,1,0),COLOR8080FF;
STICKLINE((BB-VARC<0),BB,VARC,6,0),COLOR00B500;
STICKLINE((BB-VARC<0),BB,VARC,5,0),COLOR00C600;
STICKLINE((BB-VARC<0),BB,VARC,4,0),COLOR00D500;
STICKLINE((BB-VARC<0),BB,VARC,3,0),COLOR00E600;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),8,0),COLORFF5D00;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),7,0),COLORFF5D10;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),6,0),COLORFF7710;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),5,0),COLORFF8810;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),4,0),COLORFF9910;
STICKLINE(EMA(D1,3)<REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),8,0),COLORFFFFFF;
STICKLINE(EMA(D1,3)<REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),7,0),COLORFFFFFF;
STICKLINE(EMA(D1,3)<REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),6,0),COLORFFFFFF;
STICKLINE(EMA(D1,3)<REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),5,0),COLORFFFFFF;
STICKLINE(EMA(D1,3)<REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),4,0),COLORFFFFFF;
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

0

主题

4

帖子

0

贡献值

初学乍练

Rank: 1

现货币
7 枚
在线时间
0 小时
发表于 2016-7-2 23:06:40 | 显示全部楼层
N:=5; C增比:=C/REF(C,1); C均增比:=(C增比+REF(C增比,1)+REF(C增比,2)+REF(C增比,3)+REF(C增比,4))/5; YC:=C*C均增比; 强弱:=COUNT(YC>REF(YC,1),10)/COUNT(YC<REF(YC,1),10); A:=EMA(EMA(EMA(EMA(强弱,2),2),2),2); B:=EMA(EMA(EMA(EMA(强弱,5),5),5),5); 快线红:EMA(EMA(EMA(EMA(YC,2),2),2),2),COLORRED,LINETHICK2; 慢线绿:EMA(EMA(EMA(EMA(YC,5),5),5),5),COLORGREEN,LINETHICK2; STICKLINE(快线红>慢线绿,快线红,慢线绿,1,0),COLORRED; STICKLINE(快线红<慢线绿,快线红,慢线绿,1,0),COLOR00CC00; VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR3:=REF(VAR2,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR5:=REF(VAR4,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR7:=REF(VAR6,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR9:=REF(VAR8,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VARB:=REF(VARA,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2); VARE:=REF(VARD,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR10:=REF(VARF,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR12:=REF(VAR11,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR14:=REF(VAR13,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR16:=REF(VAR15,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2); VAR18:=REF(VAR17,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2); VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1; STICKLINE(VAR19,L-0.03,L-0.03,15,0),LINETHICK3,COLORMAGENTA; VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD; STICKLINE(VAR1A,H*1.001,H,15,0),COLOR00FF00{98FD}; MTM:=C-REF(C,1); DX1:=100*EMA(EMA(MTM,N),N)/EMA(EMA(ABS(MTM),N),N); 买1:=IF(LLV(DX1,2)=LLV(DX1,7) AND COUNT(DX1<0,2) AND CROSS(DX1,MA(DX1,2)),1,0); 卖1:=IF(HHV(DX1,2)=HHV(DX1,7) AND COUNT(DX1>50,2) AND CROSS(MA(DX1,2),DX1),1,0); DRAWTEXT(filter(卖1=1,5),high*1.02, ' '),color00ff00,ALIGN1; DRAWTEXT(filter(买1=1,5),low*0.99, ' '),colorRED,ALIGN1; DRAWICON(filter(买1=1,5),low*0.99,7),ALIGN1; DRAWICON(filter(卖1=1,5),high*1.04, 8),ALIGN1;
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

0

主题

39

帖子

0

贡献值

登堂入室

Rank: 2

现货币
85 枚
在线时间
24 小时
发表于 2019-6-7 15:41:12 | 显示全部楼层

VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR8:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
BB:=EMA((VAR6-VAR8)/(VARB-VAR8)*100,13);
VARC:=EMA(0.667*REF(BB,1)+0.333*BB,2);
波:BB,POINTDOT,COLOR0000A8;
RSV1:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K1:=SMA(RSV1,13,1);
D1:=SMA(K1,13,1);
浪:EMA(D1,3),LINETHICK0,POINTDOT,COLORYELLOW;
天界:90,COLORF00FF0;
中界:50,POINTDOT,COLORWHITE;
地界:10,COLOR00FF00;
VAR1:=(HIGH+LOW+CLOSE)/3;
VAR2:=(VAR1-MA(VAR1,14))/(0.015*AVEDEV(VAR1,14));
VAR28:=IF(DATE<=1120930,1,0);
VAR3:=(VAR1-MA(VAR1,70))/(0.015*AVEDEV(VAR1,70));
VAR4:=IF(VAR2>=150 AND VAR2<200 AND VAR3>=150 AND VAR3<200,10,0);
VAR5:=IF(VAR2<=-150 AND VAR2>-200 AND VAR3<=-150 AND VAR3>-200,-10,VAR4);
VAR16:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR7:=100-ABS(VAR16);
VAR18:=IF(VAR7<90,VAR7,100);
PJX:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
短期强弱:=PJX*VAR28,LINETHICK2,COLORFFFFFF;
VAR1A:=IF(PJX>0,PJX,0);
VAR1B:=IF(VAR3>=200 AND VAR2>=150,15,IF(VAR3<=-200 AND VAR2<=-150,-15,VAR5))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR18<100;
VAR1D:=VAR1A<48 AND VAR1B<60 AND VAR18<100;
DRAWTEXT(VAR1D AND COUNT(VAR1D,30)=1,80,'短线反弹'),COLORFFFFFF;
STICKLINE(VAR1D AND COUNT(VAR1D,30)=1,60,80,5,0),COLORFFFFFF;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,80,'短线高点'),COLORFFCC66;
STICKLINE(VAR1C AND COUNT(VAR1C,30)=1,60,80,5,0),COLORFFCC66;
VAR2C:=IF(VAR3>=200 AND VAR2>=150,15,IF(VAR3<=-200 AND VAR2<=-150,-15,0))+30;
VAR2E:=VAR1A<48 AND VAR2C<30 AND VAR18<100;
VAR2F:=VAR1A<48 AND VAR2C>30 AND VAR18<100;
DRAWTEXT(VAR2E AND COUNT(VAR2E,30)=1,50,'短线反弹2'),COLORFF0000;
STICKLINE(VAR2E AND COUNT(VAR2E,30)=1,30,50,5,0),COLORFF0000;
DRAWTEXT(VAR2F AND COUNT(VAR2F,30)=1,50,'短线高点2'),COLORFFCC66;
STICKLINE(VAR2F AND COUNT(VAR2F,30)=1,30,50,5,0),COLORFFCC66;
VAR3D:=IF(VAR3<=200 AND VAR2<=150,-15,IF(VAR3>=-200 AND VAR2>=-150,15,VAR5));
VAR3E:=VAR3D>0 AND VAR18<100;
VAR3F:=VAR1A<48 AND VAR3D<0 AND VAR18<100;
DRAWTEXT(VAR7<90 AND VAR2+VAR3<=0 AND VAR3F AND COUNT(VAR3F,30)=1,20,'短线反弹3'),COLORFF0000;
STICKLINE(VAR7<90 AND VAR2+VAR3<=0 AND VAR3F AND COUNT(VAR3F,30)=1,20,0,5,0),COLORFF0000;
DRAWTEXT(VAR3E AND COUNT(VAR3E,30)=1,20,'短线高点3'),COLORFFCC66;
STICKLINE(VAR3E AND COUNT(VAR3E,30)=1,20,0,5,0),COLORFFCC66;
VAR9:=IF(VAR7<90,40,30)*VAR28;
STICKLINE(FILTER(VAR1B=45,5),0,5,5,0),COLORFFFFFF;
DRAWTEXT(FILTER(VAR1B=45,10),10,'低吸'),COLORFFFFFF;
STICKLINE(FILTER(VAR1B=75,5),90,80,5,0),COLOR00FFFF;
DRAWTEXT(FILTER(VAR1B=75,5),80,'高抛'),COLOR00FFFF;
STICKLINE(PJX<=-19,0,10,12,0),COLORFF00FF;
STICKLINE(PJX>=70,90,100,12,0),COLOR00FFFF;
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

28

主题

445

帖子

0

贡献值

功行圆满

Rank: 9Rank: 9Rank: 9

现货币
54 枚
在线时间
2088 小时
 楼主| 发表于 2012-11-6 21:46:37 | 显示全部楼层
好指标才能让 赚钱 变得简单。。。
QQ:506428606
交流群:208286276
回复 支持 反对

使用道具 举报

该用户从未签到

0

主题

333

帖子

0

贡献值

自成一派

Rank: 8Rank: 8

现货币
75 枚
在线时间
784 小时
发表于 2012-11-6 21:48:41 | 显示全部楼层
1111111111111111111111111111
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

0

主题

345

帖子

0

贡献值

略有小成

Rank: 5Rank: 5

现货币
340 枚
在线时间
200 小时
发表于 2012-11-6 21:51:24 | 显示全部楼层
[s:533]  [s:534]  [s:535]  [s:536]  [s:538]
希望能和朋友们一起交流现货投资 Q99925768
回复 支持 反对

使用道具 举报

该用户从未签到

0

主题

304

帖子

0

贡献值

初窥堂奥

Rank: 4

现货币
4 枚
在线时间
129 小时
发表于 2012-11-6 21:52:36 | 显示全部楼层
[s:538]  [s:537]  [s:542]  [s:541]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

6

主题

148

帖子

0

贡献值

略有小成

Rank: 5Rank: 5

现货币
261 枚
在线时间
236 小时
发表于 2012-11-6 21:58:06 | 显示全部楼层
[s:542]  [s:542]  [s:542]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

78

主题

1141

帖子

0

贡献值

登峰造极

Rank: 10Rank: 10Rank: 10

现货币
1208 枚
在线时间
2410 小时
发表于 2012-11-6 21:59:03 | 显示全部楼层
[s:534]  [s:534]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

0

主题

49

帖子

0

贡献值

初窥堂奥

Rank: 4

现货币
1 枚
在线时间
126 小时
发表于 2012-11-6 22:06:22 | 显示全部楼层
[s:545]  [s:542]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

该用户从未签到

15

主题

430

帖子

0

贡献值

功行圆满

Rank: 9Rank: 9Rank: 9

现货币
35255 枚
在线时间
476 小时
发表于 2012-11-6 22:06:52 | 显示全部楼层
ffsrwsduffyhvcdgggggggghhhhhhfffffff
顺势而为
回复 支持 反对

使用道具 举报

签到天数: 3 天

[LV.2]偶尔看看I

17

主题

626

帖子

0

贡献值

自成一派

Rank: 8Rank: 8

现货币
765 枚
在线时间
738 小时
发表于 2012-11-6 22:10:38 | 显示全部楼层
555555555555555
现货海:遵纪守法 各抒己见 百家争鸣 创造价值
回复 支持 反对

使用道具 举报

发表回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表